PDA

View Full Version : Question on Lab Practice Scenario for Configuring NAT



gauthierda
04-03-2009, 01:15 PM
I'm a newbie and I have a question regarding the practice scenario lab included with the CCNA Certification Kit. The exercise includes defining a NAT pool GADGET-NAT-POOL using subnet 40.0.0.16/28. When defining such a pool, are the network and broadcast addresses legitimate pool addresses, or should the pool start with 40.0.0.17 and end with 40.0.0.30?

The suggested correct answer in the lab includes not only the network and broadcast address, but the network address for the 40.0.0.32 subnet as well. Doesn't seem right to me.
Solution

To receive full credit for your answer, you should configure each device as follows:
2811 Router Configuration
NAT-Router-1>enable
NAT-Router-1#conf t
NAT-Router-1(config)#ip nat pool GADGET-NAT-POOL 40.0.0.16 40.0.0.32 netmask 255.255.255.240
NAT-Router-1(config)#ip nat inside source list 1 pool GADGET-NAT-POOL overload
NAT-Router-1(config)#access-list 1 permit 20.1.1.0 0.0.0.255
NAT-Router-1(config)#ip route 0.0.0.0 0.0.0.0 75.0.0.1
NAT-Router-1(config)#interface FastEthernet 0/0
NAT-Router-1(config-if)#ip nat outside
NAT-Router-1(config-if)#interface Serial 0/0/0
NAT-Router-1(config-if)#ip nat inside
NAT-Router-1(config-if)#exit
NAT-Router-1(config)#exit
NAT-Router-1#copy running-config startup-config


2811 Router Configuration
GADET-1>enable
GADET-1#conf t
GADET-1(config)#ip route 0.0.0.0 0.0.0.0 20.1.1.5
GADET-1(config)#exit
GADET-1#copy running-config startup-config

2811 Router Configuration
ISP-UUCOM>enable
ISP-UUCOM#conf t
ISP-UUCOM(config)#ip route 40.0.0.16 255.255.255.240 75.0.0.2
ISP-UUCOM(config)#exit
ISP-UUCOM #copy running-config startup-config

justina
08-27-2013, 11:43 AM
I'm a newbie and I have a question regarding the practice scenario lab included with the CCNA Certification Kit. The exercise includes defining a NAT pool GADGET-NAT-POOL using subnet 40.0.0.16/28. When defining such a pool, are the network and broadcast addresses legitimate pool addresses, or should the pool start with 40.0.0.17 and end with 40.0.0.30?

The suggested correct answer in the lab includes not only the network and broadcast address, but the network address for the 40.0.0.32 subnet as well. Doesn't seem right to me.
Solution

To receive full credit for your answer, you should configure each device as follows:
2811 Router Configuration
NAT-Router-1>enable
NAT-Router-1#conf t
NAT-Router-1(config)#ip nat pool GADGET-NAT-POOL 40.0.0.16 40.0.0.32 netmask 255.255.255.240
NAT-Router-1(config)#ip nat inside source list 1 pool GADGET-NAT-POOL overload
NAT-Router-1(config)#access-list 1 permit 20.1.1.0 0.0.0.255
NAT-Router-1(config)#ip route 0.0.0.0 0.0.0.0 75.0.0.1
NAT-Router-1(config)#interface FastEthernet 0/0
NAT-Router-1(config-if)#ip nat outside
NAT-Router-1(config-if)#interface Serial 0/0/0
NAT-Router-1(config-if)#ip nat inside
NAT-Router-1(config-if)#exit
NAT-Router-1(config)#exit
NAT-Router-1#copy running-config startup-config


2811 Router Configuration
GADET-1>enable
GADET-1#conf t
GADET-1(config)#ip route 0.0.0.0 0.0.0.0 20.1.1.5
GADET-1(config)#exit
GADET-1#copy running-config startup-config

2811 Router Configuration
ISP-UUCOM>enable
ISP-UUCOM#conf t
ISP-UUCOM(config)#ip route 40.0.0.16 255.255.255.240 75.0.0.2
ISP-UUCOM(config)#exit
ISP-UUCOM #copy running-config startup-config

I had trouble understanding this for a while until I explore using the ? at the end of every entry. After you name you nat pool and put a ? it says (put start network) this means you need to put the beginning network with the subnet 40.0.0.16/28 and that answer is 40.0.0.16.

After that you put a ? and it says (put end network) means you have to put the last host address of that subnet which is 40.0.0.31. /28 is 255.255.255.240, and when you take 256-240 you get 16 which is the block size of the network. 16+16 is 32 then you would put 40.0.0.31 not .32 because .32 is the next subnet.

The reason for this is that router needs to know what subnet needs the NAT/PAT to connect to the internet. This would convert the whole pool of host in that subnet into 1 address. I hope this helps you and good luck on your CCNA exam when you take it. I take my exam on Thursday Aug 29th.